IPAM Server needs SQL Server Enterprise Edition


Although this is marked nowhere in the installation documentation, but only in one blog post about moving IPAM database between servers or instances, please be careful when designing your IPAM solution. As of today, in Windows 2012R2, your database for an IPAM server can only be:

  • Windows Internal Database (Windows 2012 and WIndows 2012R2)
  • SQL Server Enterprise Edition (Windows 2012R2)

SQL Server Express Edition is not supported which may not surprise you, but the SQL Server Standard Edition isn’t also.

If you try to provision your IPAM Server with a non-supported edition, you’ll get one of the following error messages:IPAM SQL Server Enterprise eroor message

  • “IPAM supports only Enterprise Edition of SQL server but Express Edition of SQL Server is installed on %computername%”
  • “IPAM supports only Enterprise Edition of SQL server but Standard Edition of SQL Server is installed on %computername%”

Reasons other than commercial limitations are unknown since it aldso works with Windows Internal Database

Leave a comment

Your email address will not be published. Required fields are marked *